Re: [QuantLib-svn] SF.net SVN: quantlib:[16177] trunk/QuantLib

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: [QuantLib-svn] SF.net SVN: quantlib:[16177] trunk/QuantLib

Luigi Ballabio
On Thu, 2009-04-16 at 17:40 +0000, [hidden email] wrote:
> Revision: 16177
>           http://quantlib.svn.sourceforge.net/quantlib/?rev=16177&view=rev
> Author:   nando
> Date:     2009-04-16 17:40:01 +0000 (Thu, 16 Apr 2009)
>
> Log Message:
> -----------
> - removed Bond::faceAmount, as it is now ambiguous for amortizing bonds

We could disambiguate instead (initialFaceAmount/currentFaceAmount?)

> - a warning might be added in ConvertibleBond documentation stating
> that its behavior is unspecified in the case of amortizing bonds

Right. Or we could check constant notional as a precondition.

Luigi


--

Don't let school get in the way of your education.
-- Mark Twain



------------------------------------------------------------------------------
Stay on top of everything new and different, both inside and
around Java (TM) technology - register by April 22, and save
$200 on the JavaOne (SM) conference, June 2-5, 2009, San Francisco.
300 plus technical and hands-on sessions. Register today.
Use priority code J9JMT32. http://p.sf.net/sfu/p
_______________________________________________
QuantLib-dev mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/quantlib-dev
Reply | Threaded
Open this post in threaded view
|

Re: [QuantLib-svn] SF.net SVN: quantlib:[16177] trunk/QuantLib

Ferdinando Ametrano-4
On Mon, Apr 20, 2009 at 5:21 PM, Luigi Ballabio
<[hidden email]> wrote:
>> - removed Bond::faceAmount, as it is now ambiguous for amortizing bonds
>
> We could disambiguate instead (initialFaceAmount/currentFaceAmount?)

what would be the difference with notional() ? Aren't notionals() and
notional(Date d = Date()) that should be renamed faceAmounts() and
faceAmount(Date d = Date()) respectively?

ciao -- Nando

------------------------------------------------------------------------------
Stay on top of everything new and different, both inside and
around Java (TM) technology - register by April 22, and save
$200 on the JavaOne (SM) conference, June 2-5, 2009, San Francisco.
300 plus technical and hands-on sessions. Register today.
Use priority code J9JMT32. http://p.sf.net/sfu/p
_______________________________________________
QuantLib-dev mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/quantlib-dev
Reply | Threaded
Open this post in threaded view
|

Re: [QuantLib-svn] SF.net SVN: quantlib:[16177] trunk/QuantLib

Ferdinando Ametrano-4
In reply to this post by Luigi Ballabio
On Mon, Apr 20, 2009 at 5:21 PM, Luigi Ballabio
<[hidden email]> wrote:
>> - removed Bond::faceAmount, as it is now ambiguous for amortizing bonds
>
> We could disambiguate instead (initialFaceAmount/currentFaceAmount?)

what would be the difference with notional() ? Aren't notionals() and
notional(Date d = Date()) that should be renamed faceAmounts() and
faceAmount(Date d = Date()) respectively?

If I have a notional of 1M of a given bond whose face amount is 100, I
actually own 10,000 bonds, isn't it?

ciao -- Nando

------------------------------------------------------------------------------
Stay on top of everything new and different, both inside and
around Java (TM) technology - register by April 22, and save
$200 on the JavaOne (SM) conference, June 2-5, 2009, San Francisco.
300 plus technical and hands-on sessions. Register today.
Use priority code J9JMT32. http://p.sf.net/sfu/p
_______________________________________________
QuantLib-dev mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/quantlib-dev
Reply | Threaded
Open this post in threaded view
|

Re: [QuantLib-svn] SF.net SVN: quantlib:[16177] trunk/QuantLib

Luigi Ballabio
On Mon, 2009-04-20 at 17:33 +0200, Ferdinando Ametrano wrote:
> On Mon, Apr 20, 2009 at 5:21 PM, Luigi Ballabio
> <[hidden email]> wrote:
> >> - removed Bond::faceAmount, as it is now ambiguous for amortizing bonds
> >
> > We could disambiguate instead (initialFaceAmount/currentFaceAmount?)
>
> what would be the difference with notional() ?

No difference really, just idly wondering whether we could save the old
convenience method as a shortcut to notionals().front() or whatever.
initialNotional() was just as fine.  But it's no big deal.


> If I have a notional of 1M of a given bond whose face amount is 100, I
> actually own 10,000 bonds, isn't it?

Now if your strategy was to confuse me, you succeeded.  Are you telling
me we're using the wrong term and we should use faceAmount instead of
notional? Or are you telling me that the face amount should be in the
same basis as the price (you aren't, are you?)

Luigi


--

fix, n.,v.
What one does when a problem has been reported too many times
to be ignored.
-- the Jargon file



------------------------------------------------------------------------------
Stay on top of everything new and different, both inside and
around Java (TM) technology - register by April 22, and save
$200 on the JavaOne (SM) conference, June 2-5, 2009, San Francisco.
300 plus technical and hands-on sessions. Register today.
Use priority code J9JMT32. http://p.sf.net/sfu/p
_______________________________________________
QuantLib-dev mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/quantlib-dev
Reply | Threaded
Open this post in threaded view
|

Re: [QuantLib-svn] SF.net SVN: quantlib:[16177] trunk/QuantLib

Ferdinando Ametrano-4
On Mon, Apr 20, 2009 at 6:00 PM, Luigi Ballabio
<[hidden email]> wrote:
> Are you telling me we're using the wrong term and we should use
> faceAmount instead of notional?

yes I am.

Here's my 0.02€: the face amount is the bond's nominal outstanding
debt which will be redeemed at maturity (or during bond's life for
amortizing bonds). The notional of a bond is the face amount times
number of bonds.

ciao -- Nando

------------------------------------------------------------------------------
Stay on top of everything new and different, both inside and
around Java (TM) technology - register by April 22, and save
$200 on the JavaOne (SM) conference, June 2-5, 2009, San Francisco.
300 plus technical and hands-on sessions. Register today.
Use priority code J9JMT32. http://p.sf.net/sfu/p
_______________________________________________
QuantLib-dev mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/quantlib-dev