Re: unreferenced formal parameters in Commodity unitofmeasureconversion code

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: unreferenced formal parameters in Commodity unitofmeasureconversion code

Ferdinando M. Ametrano-3
Hi all

I've fixed what I think is a bug in UnitOfMeasureConversion and
consequently enabled some commented out code in
UnitOfMeasureConversionManager:
http://quantlib.svn.sourceforge.net/viewvc/quantlib?view=rev&revision=16858

anyone using (or interested into) the commodity code please take a look at it

ciao -- Nando

On Fri, Nov 27, 2009 at 12:23 PM, Ferdinando Ametrano
<[hidden email]> wrote:

> Hi all
>
> as you probably guessed I'm doing some lint activity for 1.0 release,
> so expect some more "unreferenced formal parameters" message from me.
>
> Feel free to trash all of them ;-) but if you are the author or you
> have some familiarity with the code referenced please consider helping
>
> warning C4100: 'forbidden' : unreferenced formal
> parameter       c:\Projects\QuantLib\trunk\QuantLib\ql\experimental\commodities\unitofmeasureconversionmanager.cpp      176
> warning C4100: 'r2' : unreferenced formal
> parameter       c:\Projects\QuantLib\trunk\QuantLib\ql\experimental\commodities\unitofmeasureconversion.cpp     71
>
> For unreferenced formal parameter there are 3 possible alternatives:
>
> 1) keep the parameter, just remove its name. This might be the case if
> you're inheriting the signature, but the parameter doesn't make sense
> in your implementation
> 2) use the parameter. Not using it was a genuine bug
> 3) remove the parameter as it is not needed
>
> ciao -- Nando
>
> RSS feed: http://www.google.com/reader/shared/ferdinando.ametrano
>

------------------------------------------------------------------------------
Join us December 9, 2009 for the Red Hat Virtual Experience,
a free event focused on virtualization and cloud computing.
Attend in-depth sessions from your desk. Your couch. Anywhere.
http://p.sf.net/sfu/redhat-sfdev2dev
_______________________________________________
QuantLib-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/quantlib-users
Reply | Threaded
Open this post in threaded view
|

Re: [Quantlib-dev] unreferenced formal parameters in Commodity unitofmeasureconversion code

Luigi Ballabio
On Thu, 2009-12-03 at 15:47 +0100, Ferdinando Ametrano wrote:
> I've fixed what I think is a bug in UnitOfMeasureConversion and
> consequently enabled some commented out code in
> UnitOfMeasureConversionManager:
> http://quantlib.svn.sourceforge.net/viewvc/quantlib?view=rev&revision=16858
>
> anyone using (or interested into) the commodity code please take a look at it

Done. For the readability of the logic, I much preferred directLookup
and smartLookup to lookupImpl(true) and lookupImpl(false).

Luigi


--

If you can't convince them, confuse them.
-- Harry S. Truman



------------------------------------------------------------------------------
Join us December 9, 2009 for the Red Hat Virtual Experience,
a free event focused on virtualization and cloud computing.
Attend in-depth sessions from your desk. Your couch. Anywhere.
http://p.sf.net/sfu/redhat-sfdev2dev
_______________________________________________
QuantLib-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/quantlib-users
Reply | Threaded
Open this post in threaded view
|

Re: [Quantlib-dev] unreferenced formal parameters in Commodity unitofmeasureconversion code

Luigi Ballabio
On Thu, 2009-12-03 at 15:54 +0100, Luigi Ballabio wrote:

> On Thu, 2009-12-03 at 15:47 +0100, Ferdinando Ametrano wrote:
> > I've fixed what I think is a bug in UnitOfMeasureConversion and
> > consequently enabled some commented out code in
> > UnitOfMeasureConversionManager:
> > http://quantlib.svn.sourceforge.net/viewvc/quantlib?view=rev&revision=16858
> >
> > anyone using (or interested into) the commodity code please take a look at it
>
> Done. For the readability of the logic, I much preferred directLookup
> and smartLookup to lookupImpl(true) and lookupImpl(false).

...and from what I see, the smart lookup is still broken.
I'll give it a look later.

Luigi


--

Steinbach's Guideline for Systems Programming:
Never test for an error condition you don't know how to handle.



------------------------------------------------------------------------------
Join us December 9, 2009 for the Red Hat Virtual Experience,
a free event focused on virtualization and cloud computing.
Attend in-depth sessions from your desk. Your couch. Anywhere.
http://p.sf.net/sfu/redhat-sfdev2dev
_______________________________________________
QuantLib-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/quantlib-users